GLOBAL_CCU4: Data Structures

GLOBAL_CCU4
  • Home
  • Data Structures
  • Data Structure Index
  • Data Fields
Data Structures
Here are the data structures with brief descriptions:
\ C GLOBAL_CCU4


GLOBAL_CCU4: GLOBAL_CCU4 Struct Reference

GLOBAL_CCU4
  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields
GLOBAL_CCU4 Struct Reference
Data structures

Detailed Description

This saves the context of the GLOBAL_CCU4 APP.

Definition at line 124 of file GLOBAL_CCU4.h.

#include <GLOBAL_CCU4.h>

Data Fields

const uint32_t | module_frequency
const XMC_SCU_CCU_TRIGGER_t | syncstart_trigger_msk
XMC_CCU4_MODULE_t *const | module_ptr
XMC_CCU4_SLICE_MCMS_ACTION_t const | mcs_action
bool | is_initialized

Field Documentation

bool GLOBAL_CCU4::is_initialized

Indicates initialized state of particular instance of the APP

Definition at line 130 of file GLOBAL_CCU4.h.

Referenced by GLOBAL_CCU4_Init().

XMC_CCU4_SLICE_MCMS_ACTION_t const GLOBAL_CCU4::mcs_action

Shadow transfer of selected values in multi-channel mode

Definition at line 129 of file GLOBAL_CCU4.h.

Referenced by GLOBAL_CCU4_Init().

const uint32_t GLOBAL_CCU4::module_frequency

fccu frequency

Definition at line 126 of file GLOBAL_CCU4.h.

XMC_CCU4_MODULE_t* const GLOBAL_CCU4::module_ptr

reference to module handle

Definition at line 128 of file GLOBAL_CCU4.h.

Referenced by GLOBAL_CCU4_Init().

const XMC_SCU_CCU_TRIGGER_t GLOBAL_CCU4::syncstart_trigger_msk

Mask to start the timers synchronously

Definition at line 127 of file GLOBAL_CCU4.h.

The documentation for this struct was generated from the following file:
  • GLOBAL_CCU4.h


GLOBAL_CCU4: Data Structure Index

GLOBAL_CCU4
  • Data Structures
  • Data Structure Index
  • Data Fields
Data Structure Index
G
G
GLOBAL_CCU4
G


GLOBAL_CCU4: Data Fields

GLOBAL_CCU4
  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:
  • is_initialized : GLOBAL_CCU4
  • mcs_action : GLOBAL_CCU4
  • module_frequency : GLOBAL_CCU4
  • module_ptr : GLOBAL_CCU4
  • syncstart_trigger_msk : GLOBAL_CCU4


GLOBAL_CCU4: Data Fields - Variables

GLOBAL_CCU4
  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • is_initialized : GLOBAL_CCU4
  • mcs_action : GLOBAL_CCU4
  • module_frequency : GLOBAL_CCU4
  • module_ptr : GLOBAL_CCU4
  • syncstart_trigger_msk : GLOBAL_CCU4


GLOBAL_CCU4: File List

GLOBAL_CCU4
  • File List
  • Globals
File List
Here is a list of all documented files with brief descriptions:


GLOBAL_CCU4: GLOBAL_CCU4.c File Reference

GLOBAL_CCU4
  • File List
  • Globals
  • Code
Functions
GLOBAL_CCU4.c File Reference

Detailed Description

Date
2016-02-10

NOTE: This file is generated by DAVE. Any manual modification done to this file will be lost when the code is regenerated.

Definition in file GLOBAL_CCU4.c.

#include "global_ccu4.h"

Functions

DAVE_APP_VERSION_t | GLOBAL_CCU4_GetAppVersion (void)
Get GLOBAL_CCU4 APP version. More...
GLOBAL_CCU4_STATUS_t | GLOBAL_CCU4_Init (GLOBAL_CCU4_t *handle)
Initializes a GLOBAL_CCU4 with generated configuration. More...

Function Documentation

GLOBAL_CCU4_STATUS_t GLOBAL_CCU4_Init ( GLOBAL_CCU4_t * handle )

Initializes a GLOBAL_CCU4 with generated configuration.

Parameters
handle pointer to the GLOBAL_CCU4 APP handle structure.
Returns
GLOBAL_CCU4_STATUS_t
GLOBAL_CCU4_STATUS_SUCCESS : if initialization is successful
GLOBAL_CCU4_STATUS_FAILURE : if initialization is failed

Description:
  • Enable the module.
  • Start the prescaler.

Example Usage:

#include "DAVE.h"
int main(void)
{
DAVE_STATUS_t init_status;
init_status = DAVE_Init(); // GLOBAL_CCU4_Init(&GLOBAL_CCU4_0) will be called from DAVE_Init()
while(1)
{
}
return 1;
}

Definition at line 82 of file GLOBAL_CCU4.c.

References GLOBAL_CCU4_STATUS_SUCCESS, GLOBAL_CCU4::is_initialized, GLOBAL_CCU4::mcs_action, and GLOBAL_CCU4::module_ptr.

Go to the source code of this file.


GLOBAL_CCU4: GLOBAL_CCU4.h File Reference

GLOBAL_CCU4
  • File List
  • Globals
  • Code
Data Structures
GLOBAL_CCU4.h File Reference

Detailed Description

Date
2021-01-08

NOTE: This file is generated by DAVE. Any manual modification done to this file will be lost when the code is regenerated.

Definition in file GLOBAL_CCU4.h.

#include "xmc_ccu4.h"
#include "xmc_scu.h"
#include "DAVE_Common.h"
#include "global_ccu4_conf.h"
#include "global_ccu4_extern.h"

Data Structures

struct GLOBAL_CCU4

Typedefs

typedef struct GLOBAL_CCU4 GLOBAL_CCU4_t

Functions

DAVE_APP_VERSION_t | GLOBAL_CCU4_GetAppVersion (void)
Get GLOBAL_CCU4 APP version. More...
GLOBAL_CCU4_STATUS_t | GLOBAL_CCU4_Init (GLOBAL_CCU4_t *handle)
Initializes a GLOBAL_CCU4 with generated configuration. More...
__STATIC_INLINE void | GLOBAL_CCU4_SyncStartTriggerHigh (uint32_t ccucon_msk)
Start all the timers which are configured to start externally on positive edge.
More...
__STATIC_INLINE void | GLOBAL_CCU4_SyncStartTriggerLow (uint32_t ccucon_msk)
Start all the timers which are configured to start externally on negative edge.
More...
enum | GLOBAL_CCU4_STATUS { GLOBAL_CCU4_STATUS_SUCCESS = 0U, GLOBAL_CCU4_STATUS_FAILURE }
Return status of the GLOBAL_CCU4 APP. More...
typedef enum GLOBAL_CCU4_STATUS | GLOBAL_CCU4_STATUS_t
Return status of the GLOBAL_CCU4 APP.

Go to the source code of this file.


GLOBAL_CCU4: Globals

GLOBAL_CCU4
  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:
  • GLOBAL_CCU4_GetAppVersion() : GLOBAL_CCU4.c , GLOBAL_CCU4.h
  • GLOBAL_CCU4_Init() : GLOBAL_CCU4.h , GLOBAL_CCU4.c
  • GLOBAL_CCU4_STATUS : GLOBAL_CCU4.h
  • GLOBAL_CCU4_STATUS_FAILURE : GLOBAL_CCU4.h
  • GLOBAL_CCU4_STATUS_SUCCESS : GLOBAL_CCU4.h
  • GLOBAL_CCU4_STATUS_t : GLOBAL_CCU4.h
  • GLOBAL_CCU4_SyncStartTriggerHigh() : GLOBAL_CCU4.h
  • GLOBAL_CCU4_SyncStartTriggerLow() : GLOBAL_CCU4.h
  • GLOBAL_CCU4_t : GLOBAL_CCU4.h


GLOBAL_CCU4: Globals

GLOBAL_CCU4
  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • GLOBAL_CCU4_GetAppVersion() : GLOBAL_CCU4.c , GLOBAL_CCU4.h
  • GLOBAL_CCU4_Init() : GLOBAL_CCU4.h , GLOBAL_CCU4.c
  • GLOBAL_CCU4_SyncStartTriggerHigh() : GLOBAL_CCU4.h
  • GLOBAL_CCU4_SyncStartTriggerLow() : GLOBAL_CCU4.h


GLOBAL_CCU4: Globals

GLOBAL_CCU4
  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • GLOBAL_CCU4_STATUS_t : GLOBAL_CCU4.h
  • GLOBAL_CCU4_t : GLOBAL_CCU4.h


GLOBAL_CCU4: Globals

GLOBAL_CCU4
  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • GLOBAL_CCU4_STATUS : GLOBAL_CCU4.h


GLOBAL_CCU4: Globals

GLOBAL_CCU4
  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • GLOBAL_CCU4_STATUS_FAILURE : GLOBAL_CCU4.h
  • GLOBAL_CCU4_STATUS_SUCCESS : GLOBAL_CCU4.h


GLOBAL_CCU4: GLOBAL_CCU4.c Source File

GLOBAL_CCU4
  • File List
  • Globals
  • Code
GLOBAL_CCU4.c
Go to the documentation of this file.
1
48 /***********************************************************************************************************************
49 * HEADER FILES
50 **********************************************************************************************************************/
51
52 #include "global_ccu4.h"
53
54 /***********************************************************************************************************************
55 * MACROS
56 **********************************************************************************************************************/
57
58 /***********************************************************************************************************************
59 * LOCAL DATA
60 **********************************************************************************************************************/
61
62 /***********************************************************************************************************************
63 * LOCAL ROUTINES
64 **********************************************************************************************************************/
65
66 /**********************************************************************************************************************
67 * API IMPLEMENTATION
68 **********************************************************************************************************************/
69 /* Returns the version of the GLOBAL_CCU4 APP. */
70 DAVE_APP_VERSION_t GLOBAL_CCU4_GetAppVersion(void)
71 {
72 DAVE_APP_VERSION_t version;
73
74 version.major = GLOBAL_CCU4_MAJOR_VERSION;
75 version.minor = GLOBAL_CCU4_MINOR_VERSION;
76 version.patch = GLOBAL_CCU4_PATCH_VERSION;
77
78 return version;
79 }
80
81 /* Initializes the slice with the generated configuration */
82 GLOBAL_CCU4_STATUS_t GLOBAL_CCU4_Init(GLOBAL_CCU4_t* handle)
83 {
84 XMC_ASSERT("GLOBAL_CCU4_Init:NULL handler", (NULL != handle));
85
86 if (false == handle->is_initialized)
87 {
88 /* Enable CCU4 module */
89 XMC_CCU4_Init(handle->module_ptr,handle->mcs_action);
90 /* Start the prescaler */
91 XMC_CCU4_StartPrescaler(handle->module_ptr);
92 /* Restricts multiple initializations */
93 handle->is_initialized = true;
94 }
95
96 return (GLOBAL_CCU4_STATUS_SUCCESS);
97 }


GLOBAL_CCU4: GLOBAL_CCU4.h Source File

GLOBAL_CCU4
  • File List
  • Globals
  • Code
GLOBAL_CCU4.h
Go to the documentation of this file.
1
70 #ifndef GLOBAL_CCU4_H
71 #define GLOBAL_CCU4_H
72
73 /***********************************************************************************************************************
74 * HEADER FILES
75 **********************************************************************************************************************/
76 #include "xmc_ccu4.h"
77 #include "xmc_scu.h"
78 #include "DAVE_Common.h"
79 #include "global_ccu4_conf.h"
80
81 /**********************************************************************************************************************
82 * MACROS
83 **********************************************************************************************************************/
84 #define GLOBAL_CCU4_XMC_LIB_MAJOR_VERSION 2
85 #define GLOBAL_CCU4_XMC_LIB_MINOR_VERSION 0
86 #define GLOBAL_CCU4_XMC_LIB_PATCH_VERSION 0
87
88 #if !((XMC_LIB_MAJOR_VERSION > GLOBAL_CCU4_XMC_LIB_MAJOR_VERSION) ||\
89 ((XMC_LIB_MAJOR_VERSION == GLOBAL_CCU4_XMC_LIB_MAJOR_VERSION) && (XMC_LIB_MINOR_VERSION > GLOBAL_CCU4_XMC_LIB_MINOR_VERSION)) ||\
90 ((XMC_LIB_MAJOR_VERSION == GLOBAL_CCU4_XMC_LIB_MAJOR_VERSION) && (XMC_LIB_MINOR_VERSION == GLOBAL_CCU4_XMC_LIB_MINOR_VERSION) && (XMC_LIB_PATCH_VERSION >= GLOBAL_CCU4_XMC_LIB_PATCH_VERSION)))
91 #error "GLOBAL_CCU4 requires XMC Peripheral Library v2.0.0 or higher"
92 #endif
93
94 /**********************************************************************************************************************
95 * ENUMS
96 **********************************************************************************************************************/
104 typedef enum GLOBAL_CCU4_STATUS
105 {
106 GLOBAL_CCU4_STATUS_SUCCESS = 0U,
107 GLOBAL_CCU4_STATUS_FAILURE
108 } GLOBAL_CCU4_STATUS_t;
112 /***********************************************************************************************************************
113 * DATA STRUCTURES
114 ***********************************************************************************************************************/
115
124 typedef struct GLOBAL_CCU4
125 {
126 const uint32_t module_frequency;
127 const XMC_SCU_CCU_TRIGGER_t syncstart_trigger_msk;
128 XMC_CCU4_MODULE_t* const module_ptr;
129 XMC_CCU4_SLICE_MCMS_ACTION_t const mcs_action;
130 bool is_initialized;
131 } GLOBAL_CCU4_t;
132
136 /***********************************************************************************************************************
137 * API Prototypes
138 ***********************************************************************************************************************/
139 #ifdef __cplusplus
140 extern "C" {
141 #endif
142
180 DAVE_APP_VERSION_t GLOBAL_CCU4_GetAppVersion(void);
181
211 GLOBAL_CCU4_STATUS_t GLOBAL_CCU4_Init(GLOBAL_CCU4_t* handle);
212
248 __STATIC_INLINE void GLOBAL_CCU4_SyncStartTriggerHigh(uint32_t ccucon_msk)
249 {
250 XMC_SCU_SetCcuTriggerHigh(ccucon_msk);
251 }
252
288 __STATIC_INLINE void GLOBAL_CCU4_SyncStartTriggerLow(uint32_t ccucon_msk)
289 {
290 XMC_SCU_SetCcuTriggerLow(ccucon_msk);
291 }
292
298 #include "global_ccu4_extern.h"
299
300 #ifdef __cplusplus
301 }
302 #endif
303
304 #endif /*CCUGLOBAL_H*/


GLOBAL_CCU4: Code Directory Reference

GLOBAL_CCU4
  • Code
Code Directory Reference

Files

file | GLOBAL_CCU4.c [code]
file | GLOBAL_CCU4.h [code]


Generated on 09-Jan-2021 11:19:40 for GLOBAL_CCU4 Version 4.1.14


Control Name | Range/Items | Description
Clock frequency [MHz] | 0.125 to 144 | Display the fccu frequency available for the top lavel APPs. Range: For XMC4500,XMC4400,XMC4200,XMC4100 devices (in MHz): 3 to 120 For XMC4800/4700 devices (in MHz): 3 to 144 For XMC1000 devices (in MHz): 0.125 to 32
Multi channel mode shadow transfer | Period and Compare Period, Compare and Prescaler Period, Compare, Prescaler and Dither | Select the values to be updated on shadow transfer request.


APP Version | Date | Change Description
4.0.0 | 16-Feb-2015 | Initial version for DAVEv4
4.0.1 08-May-2015 1. Coding guidelines update for the PR release
2. New parameter "syncstart_trigger_msk" is added in APP handle to start the specific kernel/s
4.1.0 25-May-2015 1. API names changed
a. GLOBAL_CCU4_SyncStart_TriggerLow() --> GLOBAL_CCU4_SyncStartTriggerLow()
b. GLOBAL_CCU4_SyncStart_TriggerHigh() --> GLOBAL_CCU4_SyncStartTriggerHigh()
4.1.2 | 20-Jun-2015 | Guidelines update for PR release.
4.1.4 | 08-Jul-2015 | Updated the help doc.
4.1.6 08-Oct-2015 1. XMC14, XMC48, XMC47 device support added
2. Min, Max values are updated in UI file
4.1.8 18-Dec-2015 1. Added support for XMC4300 devices.
4.1.10 06-Jan-2016 1. Added a check for XMC4 devices, to verify that CCU clock is enabled or not in CLOCK_XMC4 APP.
4.1.12 10-Feb-2016 1. Added a check to verify that the CCU clock is enabled or not in the CLOCK_XMC4 APP.
4.1.14 09-Jan-2021 Modified check for minimum XMCLib version.


GLOBAL_CCU4: Abbreviations and Definitions

GLOBAL_CCU4
Abbreviations and Definitions

Abbreviations and Definitions

Abbreviations:
DAVE™ | Digital Application Virtual Engineer
APP | DAVE™ Application
API | Application Programming Interface
GUI | Graphical User Interface
MCU | Microcontroller Unit
SW | Software
HW | Hardware
LLD | Low Level Driver
I/O | Input/Output
CCU | Capture Compare Unit
CC | Capture Compare Slice
SCU | System Control Unit

Definitions:
Singleton | Only single instance of the APP is permitted
Sharable | Resource sharing with other APPs is permitted
initProvider | Provides the initialization routine
Physical connectivity | Hardware inter/intra peripheral (constant) signal connection
Conditional connectivity | Constrained hardware inter/intra peripheral signal connection
Aggregation | Indicates consumption of low level (dependent) DAVE™ APPs


GLOBAL_CCU4: Architecture Description

GLOBAL_CCU4
Architecture Description

Architecture Description

Figure 1 : Architecture of GLOBAL_CCU4 APP

The diagram above represents the internal software architecture of the GLOBAL_CCU4 APP. A GLOBAL_CCU4 APP instance exists in a DAVE™ project with fixed attributes as shown. Each instance of this APP configures one CCU4 module in the MCU. In addition, the APP requires the consumption of the CLOCK APP for its configuration and functioning. The GLOBAL_CCU4 APP also provides an output signal for inter-peripheral connections.An instantiated APP (after code generation) generates a specific data structure with the GUI configuration. The name of this data structure can be modified by changing the APP instance label (e.g. change label from default GLOBAL_CCU4_0 to GLOBAL_CCU4_SVM).Signals:
The following table presents the signals provided by the APP for inter-peripheral connections:Table 1: APP I/O signals

Signal Name | Input/Output | Availability | Description
ccu4_global_start | Output | Always | Global Synchronous Start: This signal can be used to connect with top level APPs like PWM to start the timers synchronously.
APPS Consumed:
The following table presents the APPs consumed to support the functionality:Table 2: APPs Consumed

APP Name | Consumption | Description
CLOCK_XMC4 | Conditionally consumed. For XMC4000 devices. | Initialise the clock settings.
CLOCK_XMC1 | Conditionally consumed. For XMC1000 devices. | Initialise the clock settings.


GLOBAL_CCU4: Methods

GLOBAL_CCU4
Methods
DAVE_APP_VERSION_t | GLOBAL_CCU4_GetAppVersion (void)
 | Get GLOBAL_CCU4 APP version. More...
GLOBAL_CCU4_STATUS_t | GLOBAL_CCU4_Init (GLOBAL_CCU4_t *handle)
 | Initializes a GLOBAL_CCU4 with generated configuration. More...
__STATIC_INLINE void | GLOBAL_CCU4_SyncStartTriggerHigh (uint32_t ccucon_msk)
 | Start all the timers which are configured to start externally on positive edge. More...
__STATIC_INLINE void | GLOBAL_CCU4_SyncStartTriggerLow (uint32_t ccucon_msk)
 | Start all the timers which are configured to start externally on negative edge. More...

Detailed Description

Methods

Function Documentation

DAVE_APP_VERSION_t GLOBAL_CCU4_GetAppVersion ( void )

Get GLOBAL_CCU4 APP version.

Returns
DAVE_APP_VERSION_t APP version information (major, minor and patch number)
Description:
The function can be used to check application software compatibility with a specific version of the APP.

Example Usage:

#include "DAVE.h"
int main(void)
{
DAVE_STATUS_t status;
DAVE_APP_VERSION_t app_version;
status = DAVE_Init(); // GLOBAL_CCU4_Init() is called from DAVE_Init()
app_version = GLOBAL_CCU4_GetAppVersion();
if (app_version.major != 4U)
{
// Probably, not the right version.
}
while(1U)
{
}
return 1;
}

Definition at line 70 of file GLOBAL_CCU4.c.

GLOBAL_CCU4_STATUS_t GLOBAL_CCU4_Init ( GLOBAL_CCU4_t * handle )

Initializes a GLOBAL_CCU4 with generated configuration.

Parameters
handle pointer to the GLOBAL_CCU4 APP handle structure.
Returns
GLOBAL_CCU4_STATUS_t
GLOBAL_CCU4_STATUS_SUCCESS : if initialization is successful
GLOBAL_CCU4_STATUS_FAILURE : if initialization is failed

Description:
  • Enable the module.
  • Start the prescaler.

Example Usage:

#include "DAVE.h"
int main(void)
{
DAVE_STATUS_t init_status;
init_status = DAVE_Init(); // GLOBAL_CCU4_Init(&GLOBAL_CCU4_0) will be called from DAVE_Init()
while(1)
{
}
return 1;
}

Definition at line 82 of file GLOBAL_CCU4.c.

References GLOBAL_CCU4_STATUS_SUCCESS, GLOBAL_CCU4::is_initialized, GLOBAL_CCU4::mcs_action, and GLOBAL_CCU4::module_ptr.

__STATIC_INLINE void GLOBAL_CCU4_SyncStartTriggerHigh ( uint32_t ccucon_msk )

Start all the timers which are configured to start externally on positive edge.

Parameters
ccucon_msk mask for which kernels sync start has to be applied.
Note:
This mask has been generated in the APP handle and as a macro in global_ccu4_conf.h file.
  1. The variable from the APP handle is useful while starting the specific kernel/s
  2. GLOBAL_CCU4_CCUCON_Msk Macro from global_ccu4_conf.h file can be used to start all the selected kernels at a time.
Return values
none
Description:
The top level APPs have to be enabled, to start the timer externally with positive trigger edge.

Example Usage:

#include "DAVE.h"
int main(void)
{
DAVE_STATUS_t status;
status = DAVE_Init(); // GLOBAL_CCU4_Init() is called from DAVE_Init()
// Below can be used to start the specific kernels, by generating two instance of APP
// GLOBAL_CCU4_SyncStartTriggerHigh((uint32_t)(GLOBAL_CCU4_0.syncstart_trigger_msk | GLOBAL_CCU4_1.syncstart_trigger_msk));
// Below can be used to start all the kernels simultaneously
GLOBAL_CCU4_SyncStartTriggerHigh(GLOBAL_CCU4_CCUCON_Msk);
while(1)
{
}
return 1;
}

Definition at line 248 of file GLOBAL_CCU4.h.

__STATIC_INLINE void GLOBAL_CCU4_SyncStartTriggerLow ( uint32_t ccucon_msk )

Start all the timers which are configured to start externally on negative edge.

Parameters
ccucon_msk mask for which kernels sync start has to be applied.
Note:
This mask has been generated in the APP handle and a macro in global_ccu4_conf.h file.
  1. The variable from the APP handle is useful while starting the specific kernel/s
  2. GLOBAL_CCU4_CCUCON_Msk Macro from global_ccu4_conf.h file can be used to start all the selected kernels at a time.
Return values
none
Description:
The top level APPs have to be enabled, to start the timer externally with negative trigger edge.

Example Usage:

#include "DAVE.h"
int main(void)
{
DAVE_STATUS_t status;
status = DAVE_Init(); // GLOBAL_CCU4_Init() is called from DAVE_Init()
// Below can be used to start the specific kernels, by generating two instance of APP
// GLOBAL_CCU4_SyncStartTriggerLow((uint32_t)(GLOBAL_CCU4_0.syncstart_trigger_msk | GLOBAL_CCU4_1.syncstart_trigger_msk));
// Below can be used to start all the kernels simultaneously
GLOBAL_CCU4_SyncStartTriggerLow(GLOBAL_CCU4_CCUCON_Msk);
while(1)
{
}
return 1;
}

Definition at line 288 of file GLOBAL_CCU4.h.


GLOBAL_CCU4: Data structures

GLOBAL_CCU4
Data Structures
Data structures

Data Structures

struct | GLOBAL_CCU4
typedef struct GLOBAL_CCU4 | GLOBAL_CCU4_t

Detailed Description

Typedef Documentation

typedef struct GLOBAL_CCU4 GLOBAL_CCU4_t

This saves the context of the GLOBAL_CCU4 APP.


GLOBAL_CCU4: Enumerations

GLOBAL_CCU4
Enumerations
enum | GLOBAL_CCU4_STATUS { GLOBAL_CCU4_STATUS_SUCCESS = 0U, GLOBAL_CCU4_STATUS_FAILURE }
 | Return status of the GLOBAL_CCU4 APP. More...
typedef enum GLOBAL_CCU4_STATUS | GLOBAL_CCU4_STATUS_t
 | Return status of the GLOBAL_CCU4 APP.

Detailed Description

Enumeration Type Documentation

enum GLOBAL_CCU4_STATUS

Return status of the GLOBAL_CCU4 APP.

Enumerator
GLOBAL_CCU4_STATUS_SUCCESS | Status success
GLOBAL_CCU4_STATUS_FAILURE | Status failure

Definition at line 104 of file GLOBAL_CCU4.h.


GLOBAL_CCU4: License Terms and Copyright Information

GLOBAL_CCU4
License Terms and Copyright Information

License Terms and Copyright Information

Copyright (c) 2016, Infineon Technologies AG All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the copyright holders nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.To improve the quality of the software, users are encouraged to share modifications, enhancements or bug fixes with Infineon Technologies AG (dave@.nosp@m.infi.nosp@m.neon..nosp@m.com).


GLOBAL_CCU4: Overview

GLOBAL_CCU4
Overview

Overview

The primary purpose of the GLOBAL_CCU4 APP is to share the common resources in the CCU4 module among top level APPs. It provides functions to accomplish the following:

  1. Enable CCU4 module
  2. Start CC4y (y = [0..3]) timers synchronously
  3. Shadow transfer of selected values (in the GUI) in multi-channel mode
Figure 1 : Hardware and Software connectivity of GLOBAL_CCU4 APP
The figure above shows the layered architecture of the GLOBAL_CCU4 APP for DAVE™. The LLD layer provides an abstraction for the CCU4 hardware module. The GLOBAL_CCU4 APP uses CCU4 and SCU LLDs for its functionality.Supported Devices
The APP supports the following devices:

  1. XMC4800/XMC4700 Series
  2. XMC4500 Series
  3. XMC4400 Series
  4. XMC4300 Series
  5. XMC4200 / XMC4100 Series
  6. XMC1400 Series
  7. XMC1300 Series
  8. XMC1200 Series
  9. XMC1100 Series
References

  1. XMC4800 / XMC4700 Reference Manual
  2. XMC4500 Reference Manual
  3. XMC4400 Reference Manual
  4. XMC4300 Reference Manual
  5. XMC4200 / XMC4100 Reference Manual
  6. XMC1400 Reference Manual
  7. XMC1300 Reference Manual
  8. XMC1200 Reference Manual
  9. XMC1100 Reference Manual


GLOBAL_CCU4: Usage

GLOBAL_CCU4
Usage

Usage

GLOBAL_CCU4 is a global DAVE™ APP. It is consumed by the PWM and other (top level) APPs. For information on how GLOBAL_CCU4 is being used, refer to the PWM related APPs help documentation. e.g.: PWM, PWM_CCU4


GLOBAL_CCU4: APP Configuration Parameters

GLOBAL_CCU4
APP Configuration Parameters

App Configuration Parameters

Figure 1: General Settings


GLOBAL_CCU4: Release History

GLOBAL_CCU4
Release History

Release History


GLOBAL_CCU4: Main Page

GLOBAL_CCU4
GLOBAL_CCU4 Documentation

Index

License Terms and Copyright Information
Abbreviations and Definitions
Overview
Architecture Description
APP Configuration Parameters
Enumerations
Data structures
Methods
Usage

Release History


GLOBAL_CCU4: Apps

GLOBAL_CCU4
Apps
Here is a list of all modules:
o License Terms and Copyright Information
o Abbreviations and Definitions
o Overview
o Architecture Description
o APP Configuration Parameters
o Enumerations
o Data structures
o Methods
o Usage
\ Release History